Martino Scanferlato Web designer logo mobile

WEB...ZONE

Blog di notizie dal mondo di Internet

01

06/2015

EU e-Privacy Directive Plugin in italiano

Categorie: html, webmarketing, varie

EU e-Privacy Directive  Plugin in italiano

EU e-Privacy Directive Vi piace ma vorreste che fosse in italiano? Presto fatto. Con il file in allegato e la giusta configurazione questo plugin parlerá il Vs. idioma.

Basta scaricare il file 'it-IT.plg_system_eprivacy.zip' dal link posto alla fine, scompattarlo e inserire il file 'it-IT.plg_system_eprivacy.ini' cosí ottenuto nella cartella /administrator/language/it-IT della Vs. installazione Joomla. Fate il refresh del sito e godetevi la nuova lingua. Va da se che se volete cambiare qualche voce (magari quella relativa all’informativa breve) dovrete aprire il file con un programma tipo Notepad++ ed editarne la giusta parte, provvedendo poi a rimetterlo nel server alla cartella indicata sopra.

EU e-Privacy Directive é una estensione Joomla creata da Michael Richey che é possibile scaricare da questo link. Risponde a una esigenza molto sentita in questi giorni di adeguamento normativo alla normativa europea sui cookies, cioé quella di bloccare i “biscottini” direttamente al primo collegamento. La normativa infatti prevede che per cookies di terze parti e per quelli di profilazione (ma non per quelli tecnici) sia necessario il consenso dell’utente prima dell’installazione. Non basta quindi che nel Vs. sito abbiate messo in bella evidenza un banner chiedendo il necessario consenso all’installazione, perché, senza blocco preventivo, quando l’utente prende visione dello stesso…ha già installato i cookies.

Questa estensione, fatta molto bene anche se non completa (manca la possibilitá per l’utente di scegliere quali cookie bloccare o ammettere), mostra un banner al primo accesso contenente l’informativa breve e contemporaneamente blocca i cookies chiedendo all’utente il consenso alla loro installazione. Se questo viene rilasciato i cookies hanno via libera, se questo viene negato i cookies non vengono installati. Tale scelta è comunque sempre modificabile dall’apposito link che compare in alto.

Di default i cookies bloccati sono tutti quelli di Joomla, ma non quelli di terze parti. Per bloccare quest’ultimi bisogna in primo luogo che il server implementi PHP nella versione 5.3 o superiore e che siano installate le PHP Reflection. Per capire se questo è il Vs. caso basta che andiate, una volta installato il plugin, nella configurazione dello stesso (estensioni/gestione plugin/eprivacy). Se alla voce Opzioni Avanzate trovate il messaggio “Your system lacks the PHP Reflection classes; as a result, this feature is not available on your server” (“Il tuo sistema non ha le classi PHP Reflection; di conseguenza, questa caratteristica non é disponibile nel tuo server.”) purtroppo non c’è niente da fare (se non far aggiornare PHP dalla societá di Hosting).

Se invece alla voce Opzioni Avanzate non trovate questo messaggio ma vi compare la scelta View Level (“Imposta livello”) e potete scegliere il livello da impostare, allora siete a posto.

Vi basterà:
a) creare un nuovo gruppo di utenti (denominato ad esempio “Accettazione Cookie”) e impostarlo con Gruppo Principale “Public”;
b) creare un nuovo livello di accesso (denominato ad esempio “Accettazione Cookie” – potete scegliere anche un nome diverso) e scegliere come gruppo di utenti il gruppo creato al punto precedente;
c) impostare il View Level di cui sopra (nelle opzione avanzate del Plugin) con il nuovo livello di visualizzazione appena creato;
d) Modificare il livello di accesso di ogni modulo che produce cookies di terze parti con il nuovo livello Accettazione Cookie.
Fatto, ora anche i cookie di terze parti saranno bloccati.
L’autore consiglia di inserire anche il modulo del login così sarà bloccato in caso di non accettazione dei cookie, ma è anche vero che lo stesso (se si limita a fare il login) produce cookies che possono considerarsi tecnici e quindi non è necessario bloccarli.
In oltre se il modulo é quello standard di Joomla anche senza modificarlo non funzionerá se l'utente ha rifiutato i cookie.
Attenzione: se l’utente sceglie di non accettare i cookie i moduli così impostati NON VERRANNO VISUALIZZATI.

Link per il download: it-IT.plg_system_eprivacy.zip.

Torna al blog
Torna all'inizio